Search found 13 matches

by cthoennes
2013-01-18, 19:10
Forum: Coding and Scripting
Topic: GUI access from map script
Replies: 7
Views: 3595

Re: GUI access from map script

Well, that wasn't about the error itself, but rather about the confusing format that the message is - that's how it looked like on the cmd. Sorry, could have formatted it. Anyway, I found it by looking into the msdn database: toPrint is a static variable, but I haven't defined it. After doing so, ev...
by cthoennes
2012-12-29, 16:06
Forum: Coding and Scripting
Topic: GUI access from map script
Replies: 7
Views: 3595

Re: GUI access from map script

OK, it partially works now. It compiles, but doesn't link, after I changed the string to char*, made the function int and static and removed all parameters from it: Infected.lib(HumanPlayer.obj) : error LNK2019: Verweis auf nicht aufgelöstes ext ernes Symbol ""public: static char * Infected::EntHuma...
by cthoennes
2012-12-29, 02:33
Forum: Coding and Scripting
Topic: GUI access from map script
Replies: 7
Views: 3595

Re: GUI access from map script

So, I modified HumanPlayer.cpp, inserted a method named drawHelpText with a text parameter into it and recompiled the source code with scons (Former CPP programmer's perk 8) Must have been of use for something) Now, after all, if I call it from the map script using "Activator:drawHelpText("Press Spa...
by cthoennes
2012-11-20, 09:20
Forum: Coding and Scripting
Topic: GUI access from map script
Replies: 7
Views: 3595

GUI access from map script

Hello, I would like to display a GUI from my map script, i.E. if the player enters a certain trigger volume, display a text on the screen (A tutorial mode). In the docs, there is the "gui" object, but it seems to be accessible only from the cgui files. Do I really need to write/build a whole new GUI...
by cthoennes
2012-09-19, 10:46
Forum: Editing and Mapping with CaWE
Topic: Glass brushes
Replies: 1
Views: 2097

Glass brushes

Hello, I have a problem here: In the wiki is written that it is possible to add a brush based entity named "func_wall" (The article was found here: http://www.cafu.de/wiki/mapping:cawe:reference:entityguide). Now, the entity exists, but I cannot set any property allowing me to make it transparent. H...
by cthoennes
2012-09-04, 19:03
Forum: Editing and Mapping with CaWE
Topic: Cut Brush
Replies: 2
Views: 2057

Re: Cut Brush

Yup... That was exactly what I was looking for. Sometimes you get a little bit blind if you only look for what you are used to see...
Anyway, that is all I need... Next Stop: My first own video game :D
(Or maybe just my next newbie post - we'll see)

Thanks a lot!
by cthoennes
2012-09-03, 22:33
Forum: Editing and Mapping with CaWE
Topic: Cut Brush
Replies: 2
Views: 2057

Cut Brush

Greetings, I "moved over" from Genesis3D (anyone remember this? Quite old one). In the Genesis World Editor there was a feature that was called Cut Brush - a normal Brush that is "negative", so it actually subtracts a part of another. That is a useful feature for making Doors, Windows and so on. Now...
by cthoennes
2012-09-03, 22:28
Forum: Editing and Mapping with CaWE
Topic: Model not placed ingame but drawn correctly in editor
Replies: 8
Views: 3932

Re: Model not placed ingame but drawn correctly in editor

@Carsten: Yes, it did... Strange enough, I thought that I used the correct path. Still, the top face of everything is missing... Even stranger? Maybe I did something wrong while exporting.
by cthoennes
2012-09-03, 20:50
Forum: Cafu Engine Support and Discussion
Topic: Material Problems in Ubuntu 11.10
Replies: 6
Views: 3186

Re: Material Problems in Ubuntu 11.10

Could you send the password to me as well? I'm at the same point having the same problem...

Thank you!
by cthoennes
2012-08-30, 22:15
Forum: Models, Materials, Textures, Sound, Music, ...
Topic: Problem with texture & model
Replies: 2
Views: 2488

Problem with texture & model

Greetings, I made a simple model (a shelf) that I inserted into a game using the tutorials provided. But after inserting it into the world/the model editor/viewing it ingame, the texture was gone - what used to be wood became a plain brown color. It was a wood texture sized 160 x 1107 Pixels, png fo...
by cthoennes
2012-08-30, 21:53
Forum: Editing and Mapping with CaWE
Topic: Model not placed ingame but drawn correctly in editor
Replies: 8
Views: 3932

Re: Model not placed ingame but drawn correctly in editor

And again, thank you. You brought me on an idea: If the game would not find it in the directory it actually is, I moved it into the Deathmatch dir... Well, it's no permanent solution, but at least it is one to work with.
Now I just need to figure out where to change the directory...
by cthoennes
2012-08-30, 20:31
Forum: Editing and Mapping with CaWE
Topic: Model not placed ingame but drawn correctly in editor
Replies: 8
Views: 3932

Re: Model not placed ingame but drawn correctly in editor

Thanks for your quick reply. Sorry, but I don't quite understand: which directory do you mean?
About the col meshes: Will do the video tutorial - but what you tell me about it sounds cool... Makes level design a load easier for me...
by cthoennes
2012-08-30, 19:53
Forum: Editing and Mapping with CaWE
Topic: Model not placed ingame but drawn correctly in editor
Replies: 8
Views: 3932

Model not placed ingame but drawn correctly in editor

Greetings, I have a small problem here: I have been working through the tutorials and added a model that was shipped with CaFu into a world I created myself. No problem here, model is loaded and displayed both in editor and in the game. Other things happened when I created a simple mesh with blender...