Cafu doesn't run for me whether compiled or from binary

Get help with installing and running the Cafu Engine here. This forum is also for general questions and discussion of all aspects regarding the Cafu Engine.
weaponx169
Posts: 9
Joined: 2012-04-21, 13:19

Cafu doesn't run for me whether compiled or from binary

Post by weaponx169 » 2012-04-23, 16:31

Hello,
I have checked out a couple of the forum posts to get this running with Ubuntu 11.10 but I just can't seem to get it to work. I tried to compile and run it on my deskop and neither option works. I keep getting X window errors both ways. I even tried it on my laptop and it didn't work.
User avatar
Haimi
Posts: 85
Joined: 2011-11-23, 09:28

Re: Cafu doesn't run for me whether compiled or from binary

Post by Haimi » 2012-04-23, 16:42

Hey Weaponx169,

I got cafu running on 3 Ubuntu 11.10 installations. Can you tell me what kind of errors you get? Do you run the binaries from the cafu root directory?
Project Status: Code architecture definition
6 Programmers, 1 Photographer, 1 Architect, 1 Game designer
User avatar
Carsten
Site Admin
Posts: 2160
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: Cafu doesn't run for me whether compiled or from binary

Post by Carsten » 2012-04-23, 23:02

Hi weaponx169,
welcome to the Cafu forums! :welcome:


Please reply to Haimi's post, :cheesy:
we need a lot more information such as system details, version numbers, error messages etc. before we can help you. :up:
Best regards,
Carsten
weaponx169
Posts: 9
Joined: 2012-04-21, 13:19

Re: Cafu doesn't run for me whether compiled or from binary

Post by weaponx169 » 2012-04-25, 15:20

weaponx69@weaponx69-HP-EliteBook-8740w:~/Desktop/Cafu$ ls
CaBSP CaWE-bin libCg.so libSoundSysOpenAL.so
Cafu CaWE-run libRendererARBprogs.so LICENSE.txt
Cafu-run config.lua libRendererCgARB1.so MakeFont
CaLight Fonts libRendererCgNV2X.so MaterialViewer
CaPVS Games libRendererNull.so Misc
CaSHL GPL.txt libRendererOpenGL12.so README.txt
CaWE libCgGL.so libSoundSysNull.so
weaponx69@weaponx69-HP-EliteBook-8740w:~/Desktop/Cafu$ ./Cafu-run
Cafu Engine, Apr 18 2012
Warning: Unable to open file config_p.lua.

Warning: Error when running config_p.lua (cannot open config_p.lua: No such file or directory).

config.lua processed.
Warning: Failed to open ZIP archive Games/DeathMatch/Textures/TechDemo.zip
Registering archive "Games/DeathMatch/Textures/SkyDomes.zip".

Scanning cwd for all available renderers...
./libRendererOpenGL12.so ... SUCCESS - first supported renderer (Pref# 1000).
./libRendererARBprogs.so ... SUCCESS - higher preference renderer (Pref# 2200).
./libRendererNull.so ... SUCCESS - but excluded from auto-selection (Pref# 1).
./libRendererCgARB1.so ... SUCCESS - but no higher preference (Pref# 2100).
./libRendererCgNV2X.so ... FAILED - renderer says it's not supported.
Reloading previously auto-selected renderer ./libRendererARBprogs.so ...

Scanning cwd for all available sound systems...
./libSoundSysOpenAL.so ... SUCCESS - first supported sound system (Pref# 1500).
./libSoundSysNull.so ... SUCCESS - but excluded from auto-selection (Pref# 1).
Reloading previously auto-selected sound system ./libSoundSysOpenAL.so ...
Available OpenAL output devices:
1. ALSA Software [default]
2. OSS Software
Available OpenAL capture devices:
1. ALSA Capture on default [default]
2. ALSA Capture on HDA Intel [STAC92xx Analog] (hw:0,0)
3. OSS Capture
Available OpenAL output devices with the ALC_ENUMERATE_ALL_EXT extension:
1. ALSA Software on default [default]
2. ALSA Software on HDA Intel [STAC92xx Analog] (hw:0,0)
3. ALSA Software on HD-Audio Generic [HDMI 0] (hw:1,3)
4. OSS Software
Warning: Console variable VideoModes is empty!
Note: Illegal Audio-MPEG-Header 0xf88e50b8 at offset 0x384.
Note: Trying to resync...
Note: Skipped 113 bytes in input.
terminate called after throwing an instance of 'std::bad_alloc'
what(): std::bad_alloc
./Cafu-run: line 3: 13818 Aborted ./Cafu
User avatar
Carsten
Site Admin
Posts: 2160
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: Cafu doesn't run for me whether compiled or from binary

Post by Carsten » 2012-04-26, 00:55

Well...
the various warnings and notes mentioned in the log are all ok, but formerly you said that you got X Window errors, whereas the log reports a std::bad_alloc exception...

What else does happen? Does it open an application window at all?

If you compiled yourself, can you run the Cafu debug binary under debugger control and post a stacktrace at the point of the exception? (I can post instructions on how to do that if required.)
It would be very much appreciated!
Best regards,
Carsten
weaponx169
Posts: 9
Joined: 2012-04-21, 13:19

Re: Cafu doesn't run for me whether compiled or from binary

Post by weaponx169 » 2012-04-26, 02:25

There is a flash of a window but it closes quickly. I also get a could not change the video notification that says;

Cafu tried to change the video mode to
1024 x 768, 32 bpp at 0 Hz,
1024 x 768, 32 bpp at any refresh rate,
1024 x 768 at any color depth and refresh rate,
but it didn't work out (zero values mean system defaults).
We will continue with the currently active video mode instead, where you can press F11 to toggle full-screen mode.

Alternatively, you can set a different video mode at the Options menu, or tweak the video mode details via the console variables.


I click okay but nothing happens. The terminal displays the message I sent earlier after I click ok.
User avatar
Carsten
Site Admin
Posts: 2160
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: Cafu doesn't run for me whether compiled or from binary

Post by Carsten » 2012-04-26, 17:40

With the version that you compiled yourself from source-code, could you please run:

Code: Select all

carsten@thubi-ubuntu:~/dev/Cafu$ gdb ./build/linux2/g++/debug/Ca3DE/Cafu
GNU gdb (GDB) 7.1-ubuntu
Copyright (C) 2010 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law.  Type "show copying"
and "show warranty" for details.
This GDB was configured as "i486-linux-gnu".
For bug reporting instructions, please see:
<http://www.gnu.org/software/gdb/bugs/>...
Reading symbols from /home/carsten/dev/Cafu/build/linux2/g++/debug/Ca3DE/Cafu...done.

(gdb) run
Starting program: /home/carsten/dev/Cafu/build/linux2/g++/debug/Ca3DE/Cafu 
[...]
Note that after the first command, you also have to type run as shown above to actually run the program.

Then when it crashes, type

Code: Select all

(gdb) bt full
[...]
and please post the full output (starting from the first command above).

:thanks:
Best regards,
Carsten
weaponx169
Posts: 9
Joined: 2012-04-21, 13:19

Re: Cafu doesn't run for me whether compiled or from binary

Post by weaponx169 » 2012-05-18, 14:33

Hi,
Sorry for the late reply. I had classes. I upgraded to Ubuntu 12.03. I don't know if you support that but I tried to compile again and I'm still getting errors. I tried to compile and run as per the instructions and I got;

brian@brian-Inspiron-537s:~/Cafu$ ls
build CaPVS CompilerSetup.py Doxygen libCgGL.so Misc
Ca3DE CaSHL CompilerSetup.pyc ExtLibs libCg.so premake4.lua
CaBSP CaTools CompilerSetup.py.tmpl Fonts libfmod-3.75.so README.txt
Cafu CaWE config.log Games Libs SConscript
CaLight Common config.lua GPL.txt LICENSE.txt SConstruct
brian@brian-Inspiron-537s:~/Cafu$ ./Cafu
Warning: Failed to open ZIP archive Games/DeathMatch/Textures/TechDemo.zip
Warning: Failed to open ZIP archive Games/DeathMatch/Textures/SkyDomes.zip
Warning: Failed to open ZIP archive Games/VSWM/Textures/TechDemo.zip
Warning: Failed to open ZIP archive Games/VSWM/Textures/SkyDomes.zip

Scanning cwd for all available renderers...
Scanning Libs/build/linux2/g++/release/MaterialSystem for all available renderers...
Libs/build/linux2/g++/release/MaterialSystem/libRendererNull.so ... SUCCESS - but excluded from auto-selection (Pref# 1).
Libs/build/linux2/g++/release/MaterialSystem/libRendererOpenGL12.so ... SUCCESS - first supported renderer (Pref# 1000).
Libs/build/linux2/g++/release/MaterialSystem/libRendererCgARB1.so ... SUCCESS - higher preference renderer (Pref# 2100).
Libs/build/linux2/g++/release/MaterialSystem/libRendererARBprogs.so ... SUCCESS - higher preference renderer (Pref# 2200).
Libs/build/linux2/g++/release/MaterialSystem/libRendererCgNV2X.so ... FAILED - renderer says it's not supported.
Reloading previously auto-selected renderer Libs/build/linux2/g++/release/MaterialSystem/libRendererARBprogs.so ...

(Cafu:9227): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

(Cafu:9227): LIBDBUSMENU-GLIB-WARNING **: Trying to remove a child that doesn't believe we're it's parent.

************************************************************************************************************************************************************************
I tried to run the debugger Carson gave me above and got;

brian@brian-Inspiron-537s:~/Cafu$ gdb ./build/linux2/g++/debug/Ca3DE/Cafu
GNU gdb (Ubuntu/Linaro 7.4-2012.04-0ubuntu2) 7.4-2012.04
Copyright (C) 2012 Free Software Foundation, Inc.
License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>
This is free software: you are free to change and redistribute it.
There is NO WARRANTY, to the extent permitted by law. Type "show copying"
and "show warranty" for details.
This GDB was configured as "i686-linux-gnu".
For bug reporting instructions, please see:
<http://bugs.launchpad.net/gdb-linaro/>...
Reading symbols from /home/brian/Cafu/build/linux2/g++/debug/Ca3DE/Cafu...done.
(gdb) run
Starting program: /home/brian/Cafu/build/linux2/g++/debug/Ca3DE/Cafu
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
Cafu Engine, May 17 2012
[New Thread 0xb6bd7b40 (LWP 9327)]
[New Thread 0xb61ffb40 (LWP 9328)]
08:30:22: Debug: Program locale set to en_GB (en_GB, English).
Warning: Unable to open file config_p.lua.

Warning: Error when running config_p.lua (cannot open config_p.lua: No such file or directory).

config.lua processed.
Warning: Failed to open ZIP archive Games/DeathMatch/Textures/TechDemo.zip
Warning: Failed to open ZIP archive Games/DeathMatch/Textures/SkyDomes.zip
(gdb) bt full
[...]
weaponx169
Posts: 9
Joined: 2012-04-21, 13:19

Re: Cafu doesn't run for me whether compiled or from binary

Post by weaponx169 » 2012-05-18, 14:45

Ok,
During one of the times I tried to run it, it worked but only after I was shutting down the machine for reboot because the reboot shut down the resolution window message. It seems like it works from one of the ways to run it. I'm trying to find out what caused it to work. I'm starting to get excited now. Thanks.
weaponx169
Posts: 9
Joined: 2012-04-21, 13:19

Re: Cafu doesn't run for me whether compiled or from binary

Post by weaponx169 » 2012-05-18, 14:51

Woohoo,
I got it to finally open. I hear sound and am able to use it but there are no maps. I downloaded and extracted the files I was given earlier but I don't see anything. I think it said this in the terminal output. Here is the output.

./build/linux2/g++/debug/Ca3DE/Cafu
Cafu Engine, May 17 2012
08:48:21: Debug: Program locale set to en_GB (en_GB, English).
Warning: Unable to open file config_p.lua.
config.lua processed.
Warning: Failed to open ZIP archive Games/DeathMatch/Textures/TechDemo.zip
Warning: Failed to open ZIP archive Games/DeathMatch/Textures/SkyDomes.zip
08:48:23: Debug: Set m_CurrentMode.w from 0 to 1920
08:48:23: Debug: Set m_CurrentMode.h from 0 to 1080

Scanning cwd for all available renderers...
Scanning Libs/build/linux2/g++/debug/MaterialSystem for all available renderers...
Libs/build/linux2/g++/debug/MaterialSystem/libRendererNull.so ... SUCCESS - but excluded from auto-selection (Pref# 1).
Libs/build/linux2/g++/debug/MaterialSystem/libRendererOpenGL12.so ...
Libs/MaterialSystem/RendererOpenGL12/RendererImpl.cpp (90): Entering RendererImplT::IsSupported().
Libs/MaterialSystem/RendererOpenGL12/RendererImpl.cpp (106): GL_VERSION string is "3.3.11627 Compatibility Profile Context".
Libs/MaterialSystem/RendererOpenGL12/RendererImpl.cpp (114): GL_ARB_multitexture_AVAIL==1.
SUCCESS - first supported renderer (Pref# 1000).
Libs/build/linux2/g++/debug/MaterialSystem/libRendererCgARB1.so ... SUCCESS - higher preference renderer (Pref# 2100).
Libs/build/linux2/g++/debug/MaterialSystem/libRendererARBprogs.so ... SUCCESS - higher preference renderer (Pref# 2200).
Libs/build/linux2/g++/debug/MaterialSystem/libRendererCgNV2X.so ... FAILED - renderer says it's not supported.
Reloading previously auto-selected renderer Libs/build/linux2/g++/debug/MaterialSystem/libRendererARBprogs.so ...

Scanning cwd for all available sound systems...
Scanning Libs/build/linux2/g++/debug/SoundSystem for all available sound systems...
Libs/build/linux2/g++/debug/SoundSystem/libSoundSysFMOD3.so ... SUCCESS - first supported sound system (Pref# 1000).
Libs/build/linux2/g++/debug/SoundSystem/libSoundSysOpenAL.so ... SUCCESS - higher preference sound system (Pref# 1500).
Libs/build/linux2/g++/debug/SoundSystem/libSoundSysNull.so ... SUCCESS - but excluded from auto-selection (Pref# 1).
Reloading previously auto-selected sound system Libs/build/linux2/g++/debug/SoundSystem/libSoundSysOpenAL.so ...
Available OpenAL output devices:
1. ALSA Software [default]
2. OSS Software
Available OpenAL capture devices:
1. ALSA Capture on default [default]
2. ALSA Capture on HDA Intel [ALC662 rev1 Analog] (hw:0,0)
3. ALSA Capture on HDA Intel [ALC662 rev1 Analog] (hw:0,2)
4. ALSA Capture on USB Device 0x46d:0x8dd [USB Audio] (hw:1,0)
5. OSS Capture
Available OpenAL output devices with the ALC_ENUMERATE_ALL_EXT extension:
1. ALSA Software on default [default]
2. ALSA Software on HDA Intel [ALC662 rev1 Analog] (hw:0,0)
3. ALSA Software on HDA ATI HDMI [HDMI 0] (hw:2,3)
4. OSS Software
Warning: Console variable VideoModes is empty!
Note: Illegal Audio-MPEG-Header 0xf88e50b8 at offset 0x384.
Note: Trying to resync...
Note: Skipped 113 bytes in input.
Warning: Lua error in call to method OnMouseButtonUp() of window with name "ButtonOK":
Games/DeathMatch/GUIs/MainMenu/MainMenu_main.cgui:654: bad argument #1 to 'GetRowText' (Index out of range.)
Warning: The call to method OnMouseButtonUp() of window with name "ButtonYes" yielded (expected return values matching signature "i>b" instead).
User avatar
Carsten
Site Admin
Posts: 2160
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: Cafu doesn't run for me whether compiled or from binary

Post by Carsten » 2012-05-18, 21:20

Hi,

good to hear you're making progress (even though nothing of the above gives a clue about where the trouble came from).

Regarding the missing maps, what does

Code: Select all

ls Games/DeathMatch/Worlds
output?
Best regards,
Carsten
weaponx169
Posts: 9
Joined: 2012-04-21, 13:19

Re: Cafu doesn't run for me whether compiled or from binary

Post by weaponx169 » 2012-05-18, 23:57

This is what I get when I type the list command like you specified above in the Cafu top directory;

brian@brian-Inspiron-537s:~/Cafu$ ls Games/DeathMatch/Worlds
AEonsCanyonTower.jpg BPWxBeta.lua Kidney.lua TechDemo.lua Worlds
AEonsCube.jpg Gotham.jpg ReNoEcho.jpg Test1.jpg
BPRockB.jpg JrBaseHQ.jpg ReNoElixir.jpg TestPatches.jpg
BPWxBeta.jpg Kidney.jpg TechDemo.jpg TestPatches.lua
User avatar
Carsten
Site Admin
Posts: 2160
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: Cafu doesn't run for me whether compiled or from binary

Post by Carsten » 2012-05-19, 11:15

Ok, the world files are missing:
Get Worlds.zip and extract it as explained at http://www.cafu.de/wiki/cppdev:gettings ... ary_assets

:up:
Best regards,
Carsten
weaponx169
Posts: 9
Joined: 2012-04-21, 13:19

Re: Cafu doesn't run for me whether compiled or from binary

Post by weaponx169 » 2012-05-19, 13:19

Alright, thank you so much for your help. It all works now. I wasn't pulling the files out into the right directory. The files extracted as a folder instead of files. The only issue now is that the program will not quit now. I have to run force quit to get out of the game. I used to be able to quit before the textures and worlds. The terminal says;

brian@brian-Inspiron-537s:~/Cafu$ ./build/linux2/g++/debug/Ca3DE/Cafu
Cafu Engine, May 17 2012
07:10:44: Debug: Program locale set to en_GB (en_GB, English).
config.lua processed.
Warning: Failed to open ZIP archive Games/DeathMatch/Textures/TechDemo.zip
Registering archive "Games/DeathMatch/Textures/SkyDomes.zip".
07:10:45: Debug: Set m_CurrentMode.w from 0 to 1920
07:10:45: Debug: Set m_CurrentMode.h from 0 to 1080

Scanning cwd for all available renderers...
Scanning Libs/build/linux2/g++/debug/MaterialSystem for all available renderers...
Libs/build/linux2/g++/debug/MaterialSystem/libRendererNull.so ... SUCCESS - but excluded from auto-selection (Pref# 1).
Libs/build/linux2/g++/debug/MaterialSystem/libRendererOpenGL12.so ...
Libs/MaterialSystem/RendererOpenGL12/RendererImpl.cpp (90): Entering RendererImplT::IsSupported().
Libs/MaterialSystem/RendererOpenGL12/RendererImpl.cpp (106): GL_VERSION string is "3.3.11627 Compatibility Profile Context".
Libs/MaterialSystem/RendererOpenGL12/RendererImpl.cpp (114): GL_ARB_multitexture_AVAIL==1.
SUCCESS - first supported renderer (Pref# 1000).
Libs/build/linux2/g++/debug/MaterialSystem/libRendererCgARB1.so ... SUCCESS - higher preference renderer (Pref# 2100).
Libs/build/linux2/g++/debug/MaterialSystem/libRendererARBprogs.so ... SUCCESS - higher preference renderer (Pref# 2200).
Libs/build/linux2/g++/debug/MaterialSystem/libRendererCgNV2X.so ... FAILED - renderer says it's not supported.
Reloading previously auto-selected renderer Libs/build/linux2/g++/debug/MaterialSystem/libRendererARBprogs.so ...

Scanning cwd for all available sound systems...
Scanning Libs/build/linux2/g++/debug/SoundSystem for all available sound systems...
Libs/build/linux2/g++/debug/SoundSystem/libSoundSysFMOD3.so ... SUCCESS - first supported sound system (Pref# 1000).
Libs/build/linux2/g++/debug/SoundSystem/libSoundSysOpenAL.so ... SUCCESS - higher preference sound system (Pref# 1500).
Libs/build/linux2/g++/debug/SoundSystem/libSoundSysNull.so ... SUCCESS - but excluded from auto-selection (Pref# 1).
Reloading previously auto-selected sound system Libs/build/linux2/g++/debug/SoundSystem/libSoundSysOpenAL.so ...
Available OpenAL output devices:
1. ALSA Software [default]
2. OSS Software
Available OpenAL capture devices:
1. ALSA Capture on default [default]
2. ALSA Capture on HDA Intel [ALC662 rev1 Analog] (hw:0,0)
3. ALSA Capture on HDA Intel [ALC662 rev1 Analog] (hw:0,2)
4. ALSA Capture on USB Device 0x46d:0x8dd [USB Audio] (hw:1,0)
5. OSS Capture
Available OpenAL output devices with the ALC_ENUMERATE_ALL_EXT extension:
1. ALSA Software on default [default]
2. ALSA Software on HDA Intel [ALC662 rev1 Analog] (hw:0,0)
3. ALSA Software on HDA ATI HDMI [HDMI 0] (hw:2,3)
4. OSS Software
Warning: Console variable VideoModes is empty!
Note: Illegal Audio-MPEG-Header 0xf88e50b8 at offset 0x384.
Note: Trying to resync...
Note: Skipped 113 bytes in input.
Warning: C++ class name for entity class name "ammo_shotgun_shells" not found.
Warning: C++ class name for entity class name "item_healthkit_small" not found.
Warning: C++ class name for entity class name "item_healthkit_small" not found.
Warning: C++ class name for entity class name "item_armor_green" not found.
Warning: C++ class name for entity class name "item_armor_green" not found.
Warning: C++ class name for entity class name "ammo_rpg_rocket" not found.
Warning: C++ class name for entity class name "ammo_rpg_rocket" not found.
Warning: C++ class name for entity class name "ammo_ARgrenades" not found.
Warning: C++ class name for entity class name "ammo_ARgrenades" not found.
Warning: C++ class name for entity class name "item_healthkit_small" not found.
Warning: C++ class name for entity class name "item_healthkit_small" not found.
Warning: C++ class name for entity class name "item_armor_green" not found.
Warning: C++ class name for entity class name "item_armor_green" not found.
Warning: C++ class name for entity class name "item_armor_green" not found.
Warning: C++ class name for entity class name "item_healthkit_small" not found.
Warning: C++ class name for entity class name "ammo_shotgun_shells" not found.
Warning: C++ class name for entity class name "ammo_shotgun_shells" not found.
Warning: C++ class name for entity class name "ammo_gausscells" not found.
Warning: C++ class name for entity class name "ammo_gausscells" not found.
Warning: C++ class name for entity class name "item_longjump" not found.
Warning: C++ class name for entity class name "item_longjump" not found.
Warning: Lua script "Games/DeathMatch/Worlds/Gotham.lua" could not be loaded
(cannot open Games/DeathMatch/Worlds/Gotham.lua: No such file or directory).
Level changed on server.
OK

Connecting to 127.0.0.1:30000
(timeout 8.0 seconds)...

PCLP: Got a connection request from 127.0.0.1:33000
[Dev] Info: Entity "Player1" of class "HumanPlayer" ("EntHumanPlayerT") instantiated.
Player joined.
Libs/MaterialSystem/MaterialManagerImpl.cpp (372): GetMaterial("Gui/Default") returns NULL.
Load World "Gotham".
Warning: Could not load the bitmap at "Games/DeathMatch/$lightmap".
Warning: Could not load the bitmap at "./file-not-found".
Warning: Could not load the bitmap at "Games/DeathMatch/Models/Weapons/Beretta/Shotgun_v_arm1_diff.png".
Note: Illegal Audio-MPEG-Header 0x00000000 at offset 0x342.
Note: Trying to resync...
Note: Skipped 417 bytes in input.
Warning: The call to method OnMouseButtonUp() of window with name "ButtonYes" yielded (expected return values matching signature "i>b" instead).
Killed
brian@brian-Inspiron-537s:~/Cafu$
User avatar
Carsten
Site Admin
Posts: 2160
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: Cafu doesn't run for me whether compiled or from binary

Post by Carsten » 2012-05-22, 23:10

weaponx169 wrote:The only issue now is that the program will not quit now. I have to run force quit to get out of the game.
I just did a fresh recompile on Ubuntu 12.04, and could not reproduce this problem: When I click on "Quit", then confirm with "Yes", the program quits normally. Also the console output that you posted doesn't show anything unusual (except the "Killed" in the last line).

How exactly do you try to quit?
Where do you click, what do you do, what happens?

Also, if it doesn't quit, could you interrupt with a debugger, and post a stacktrace? We'd at least have an idea then where the shutdown doesn't proceed...
Best regards,
Carsten
Post Reply

Who is online

Users browsing this forum: No registered users and 7 guests