Compilation Error

Get help with installing and running the Cafu Engine here. This forum is also for general questions and discussion of all aspects regarding the Cafu Engine.
Post Reply
Joined:2012-02-07, 13:06
Compilation Error

Post by MonoAlithica » 2013-02-21, 00:17

I've pulled the latest GIT code and tried to compile it with a version of the GLES renderer I'm working on, but it won't compile. I just keep getting this error straight away [image attached].


Edit:: In fact, I've just added some code to the Renderer CPP and Header files in source, but I can't seem to compile them separate from the rest of Cafu. I've tried compiling them with Cafu under Linux but the renderers don't seem to show up in the release folder at all.
User avatar
Site Admin
Joined:2004-08-19, 13:46

Re: Compilation Error

Post by Carsten » 2013-02-21, 16:44

Hi MonoAlithica,

does section "64-bit Windows with Visual C++ 2010 Express Edition" at ... iler_setup apply to you?

And some thoughts that come to mind from your screenshot:
  • Why do you call SCons with the full pathname? That should not be necessary, especially if PATH is properly set as described at
  • When you get compilation errors such as this, please copy and paste the text into a

    Code: Select all

    [code] ... 
    [/code] block here (or sent as plain-text mail to our mailing-list). Either of these is much preferrable to posting a screenshot.
Best regards,
Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests