svn compilation in ubuntu x64

Get help with installing and running the Cafu Engine here. This forum is also for general questions and discussion of all aspects regarding the Cafu Engine.
Post Reply
jngl
Posts: 2
Joined: 2010-02-07, 18:45

svn compilation in ubuntu x64

Post by jngl » 2010-02-07, 18:51

hi
when I compile, I have a error:

Code: Select all

scons: building associated VariantDir targets: build/linux2/g++/debug build/linux2/g++/release
scons: *** [build/linux2/g++/release/CaWE/CaWE] Implicit dependency `ExtLibs/wxWidgets/build-gtk_r/lib/libwx_gtk2u_gl-2.9.a' not found, needed by target `build/linux2/g++/release/CaWE/CaWE'.
JNGL
User avatar
Carsten
Site Admin
Posts: 2160
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: svn compilation in ubuntu x64

Post by Carsten » 2010-02-08, 15:23

Dear jngl,
welcome to the Cafu forums! :welcome:

This looks like the wxWidgets library could not be build in a prior step in the compilation, and unfortunately (but knowingly) SCons did not abort at that earlier error, but only subsequently when it was trying to link in the (never completed) wxWidgets library.

:arrow: Did you install all the packages mentioned in section "Linux packages" in article Getting Started with the Cafu Source Code?

If so, please delete directories build-gtk_d and build-gtk_r, that is, run

Code: Select all

 rm -rf ExtLibs/wxWidgets/build-gtk_d
rm -rf ExtLibs/wxWidgets/build-gtk_r
then re-run SCons.
If it again fails to build, please find in the output and post here the first error message where wxWidgets has a problem. Thanks! :up:
Best regards,
Carsten
jngl
Posts: 2
Joined: 2010-02-07, 18:45

Re: svn compilation in ubuntu x64

Post by jngl » 2010-02-08, 21:26

thank you!
coixcoix
Posts: 1
Joined: 2010-03-25, 21:39

Re: svn compilation in ubuntu x64

Post by coixcoix » 2010-03-25, 21:42

Thanks Charsten.
Post Reply

Who is online

Users browsing this forum: No registered users and 5 guests