Problem with Compiled Code

Get technical support about the C++ source code and about Lua scripts for maps, entities, GUIs, the console, materials, etc. Also covered are the Cafu libraries and APIs, as well as compiling, linking, and the build system.
Post Reply
TheMatrix
Posts: 20
Joined: 2004-10-19, 10:06

Problem with Compiled Code

Post by TheMatrix » 2004-10-19, 10:12

I've got a problem with my compiled source code

I compiled it with no problems, but when i want to run my dll with ca3d it returns in an error after the Ca3D Loading Screen. The Code is still the original source code, i set up the Enviroment Variable for Ca3DE and i use OpenWatcom1.2. Maybe the header file dirent.h causes the problem, i dont know. it isnt include with openwatcom, but it is included in your source code, so i downloaded a version from the Internet. Maybe its a wrong version?

I would be very pleased if you could help me and sorry for my English, I'm a German :wink:
Camille
Posts: 11
Joined: 2004-08-25, 10:03

Post by Camille » 2004-10-19, 11:07

hello !
it's a known problem... i had the solution a long time ago and i forget :oops: sorry

first you have the good version of watcom.
secondly, please e-mail cartsen to have a fix.

and please cartsen can you put it here, thanks
User avatar
Carsten
Site Admin
Posts: 2160
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Post by Carsten » 2004-10-19, 13:06

Yes, this is a problem in the current release that resulted from some cross-platform issues.
It will be fixed in the next release.
For the current release (March 2004), please look in the DeathMatch.cpp file for

Code: Select all

#include <dirent.h>
and replace it with

Code: Select all

#ifdef _WIN32
#include <direct.h>
#else
#include <dirent.h>
#endif
This fixes the problem.
Sorry for the inconvenience!
Best regards,
Carsten
TheMatrix
Posts: 20
Joined: 2004-10-19, 10:06

Post by TheMatrix » 2004-10-19, 13:36

Thanks, now it works :D
User avatar
Shadow
Posts: 195
Joined: 2004-08-28, 06:00
Location: Minesota, USofA
Contact:

Post by Shadow » 2004-10-20, 03:25

hmm i didnt not have that problem... wonder why...
i am using bloodshed dev cpp though which is another free tool
Image
PBX CONTINUES!!!
CLICK HERE!!
Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest