a terrain + a sky+a info_player_start entity=black?

A forum about everything related to the Cafu World Editor CaWE: mapping, editing, scripting, making GUIs and fonts, using the BSP, PVS and Light compilers.
changhao
Posts: 5
Joined: 2012-05-23, 09:51

a terrain + a sky+a info_player_start entity=black?

Postby changhao » 2012-05-23, 10:08

1 new map
2 add a terrain
3 then follow with a guide to add a sky
4 compile error because no info_player_start
5 add a info_player_start on the flat terrain
6 complie ok
7 enter the game with this very simple map
8 black

I think this is a valid map, a flat terrain closed with 5 sky brush,but why black?

Another problem when i build cafu with scons:
There are some no ascii chars in the comment line of the source code which make the build process stop like : 0xe4 0xfc 0x76

After i switch the code page of windows7 to German and restart the computer,
the build work.
Last edited by changhao on 2012-05-23, 15:32, edited 1 time in total.
scott
Posts: 173
Joined: 2004-08-23, 09:11

Re: a terrain + a sky+a info_player_start entity=black?

Postby scott » 2012-05-23, 14:15

Did you add a light? Did you apply a texture to the terrain?
changhao
Posts: 5
Joined: 2012-05-23, 09:51

Re: a terrain + a sky+a info_player_start entity=black?

Postby changhao » 2012-05-23, 15:39

no i did not add a light,yes i add texture for the flat terrain and sky,
and it looks ok in CaWE, but black in cafu.

i also build a closed room by hollow just one brush with no light,and it works,
both in cawe and cafu
User avatar
Carsten
Site Admin
Posts: 2143
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: a terrain + a sky+a info_player_start entity=black?

Postby Carsten » 2012-05-23, 23:24

Hi changhao,

About the terrain:
Did you run CaLight as part of the map compile process?
If you did, and the terrain is still black, can you please post a zip of the map here as an attachment?

About the compiler issue:
Thanks for the report!
Can you please post the exact error message?
Which compiler do you use?
What code page do you normally use?
(I'd love to fix this, but I'd need to be able to reproduce it first.)
Best regards,
Carsten
changhao
Posts: 5
Joined: 2012-05-23, 09:51

Re: a terrain + a sky+a info_player_start entity=black?

Postby changhao » 2012-05-24, 03:53

no , i dit not use caLight to complie,
then i switch the caLight on
but it still black in cafu game and look good in caWE

mymap.zip is the map file,and the map is very very simple , just add a terrain then follow the guide to finish the sky and texture operation , then add a info_player_start entity on the flat terrain.

i use chinaese simplified code page and vs2010
build.zip is the text out put of scons,
the error is report in chinese, which means that:
there are invalid chars for the current code page(936),please save it with unicode
[like CaBsp/LoadWorld.cpp/Line 141 ] 0xFC


thanks for your reply and great work
Attachments
mymap.zip
(277.37 KiB) Downloaded 168 times
build.zip
(818 Bytes) Downloaded 178 times
User avatar
Carsten
Site Admin
Posts: 2143
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: a terrain + a sky+a info_player_start entity=black?

Postby Carsten » 2012-05-26, 12:01

Hi changhao,

the problem with the map is caused by the info_player_start box (green) not being entirely "inside" the world.
It is easily solved though: Just raise the ceiling a bit and increase the heights of the four walls accordingly, recompile, and you should see the world properly in the engine as well.

About the codepage problem:
Thanks for the info!
It's clearly a problem that we should fix, though I'm not yet sure on how to do it best.

Can you please replace your file Cafu/Libs/Templates/Array.hpp with the attached one, and see if the compiler still reports warnings in this file?

(The attached file is the same as the old one, but encoded as UTF-8.)
Attachments
Array.hpp
(11.14 KiB) Downloaded 162 times
Best regards,
Carsten
changhao
Posts: 5
Joined: 2012-05-23, 09:51

Re: a terrain + a sky+a info_player_start entity=black?

Postby changhao » 2012-05-26, 15:04

yes the Array.hpp in utf8 works
User avatar
Carsten
Site Admin
Posts: 2143
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: a terrain + a sky+a info_player_start entity=black?

Postby Carsten » 2012-05-31, 11:52

Thanks for your reply!

I've not yet fixed this universally, but finally came up with a helpful script that I've been pondering all along:
http://trac.cafu.de/browser/tools/check_source.py

:-)
Best regards,
Carsten
zengqh
Posts: 6
Joined: 2012-08-10, 11:06

Re: a terrain + a sky+a info_player_start entity=black?

Postby zengqh » 2012-08-11, 03:10

there is another chinese guy that have the same problems...ok.
User avatar
Carsten
Site Admin
Posts: 2143
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: a terrain + a sky+a info_player_start entity=black?

Postby Carsten » 2012-08-11, 13:01

I've just committed a fix to this issue:
If you use Subversion, please update to SVN head revision.
If you don't use Subversion (please let me know!), I'll upload another set of archives later today.
Best regards,
Carsten

Return to “Editing and Mapping with CaWE”

Who is online

Users browsing this forum: No registered users and 1 guest