Some strange issues when using the Carve Tool

A forum about everything related to the Cafu World Editor CaWE: mapping, editing, scripting, making GUIs and fonts, using the BSP, PVS and Light compilers.
Tatwi
Posts: 10
Joined: 2012-08-16, 23:13

Some strange issues when using the Carve Tool

Postby Tatwi » 2012-09-18, 01:51

So, I was working on how I wanted to physically build a structure that looked essentially like a water tower (sort of a ball on top of a stick), when I discovered the following issues. I am wondering if I did something wrong to produce the issues or if it's the tool not working as intended.

1. I created a nice briezer patch sphere and applied a double sided texture to it. Awesome! However, I was not able to find a way to cut a hole in it such that one could move around inside it. Carve and Cut tools did not effect it. Bummer.

2. So I made a sphere brush, duplicated it, enlarged one and cut the smaller one in half. I placed the smaller one inside the larger one, such that a player could walk on top of the "rounded" surface of the inner sphere. If the player fell off the inner sphere, they would be walking on the inside of the outer sphere. This worked fine until I created a six sided cylinder for the tower base and placed it such that it went through the middle of all layers of the spheres except for the top. Then I used the Carve Tool with the cylinder selected and ended up with very strange, infinitely long shapes stuck to the inner sphere. In the end, I just deleted the whole thing.

3. Next I made a 360 degree arch, placed a thin box brush over the whole arch, selected the arch and used the Carved Tool. This allowed me to select and delete all the outer parts of the thin box brush, so that I could keep the center to use as a floor (and roof when duplicated). This worked great, but when I loaded the map I noticed two problems:
A. For no logical reason, when traveling on one half of the inside the object I could see all the textures normally, but traveling to the other side of the inside of the object caused all textures in all directions to turn black (even when looking back at the other side of the object).
B. The bottom texture was a simple 64px by 64px png file with an alpha channel (it looks like glass). It works great to see through, but for some strange reason when I looked through the glass, the same texture which was applied to parts of the tower shaft (a six sided cylinder) were missing completely while the other texture seemed to be missing a wedge shaped triangle in the same location on all three of the sides where that texture was applied. The strange part being that the tower shaft (six sided cylinder) looked completely normal from the ground outside of the arc-object I had made.

I would really like to use Cafu, but I keep running into weird little time sinks like this that have me wondering if it's me who is causing them or if it's the CaWE tool bugging out. I really hope that it's just me going about doing the simplest of tasks in the least efficient, most prone to causing bugs way possible, because I do enjoy working with CaWE/Cafu when it works properly. :lol:
Thank you for making Cafu!
- Rob from Canada.
www.tpot.ca
User avatar
Carsten
Site Admin
Posts: 2143
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: Some strange issues when using the Carve Tool

Postby Carsten » 2012-09-18, 10:45

Hi Rob,

thanks for your detailed report, and sorry for the trouble!

Tatwi wrote:1. I created a nice briezer patch sphere and applied a double sided texture to it. Awesome! However, I was not able to find a way to cut a hole in it such that one could move around inside it. Carve and Cut tools did not effect it. Bummer.

Yes, the Carve and Cut tools only affect brushes at this time.
Implementing this required clipping Bezier patches against planes.

2. So I made a sphere brush, duplicated it, enlarged one and cut the smaller one in half. I placed the smaller one inside the larger one, such that a player could walk on top of the "rounded" surface of the inner sphere. If the player fell off the inner sphere, they would be walking on the inside of the outer sphere. This worked fine until I created a six sided cylinder for the tower base and placed it such that it went through the middle of all layers of the spheres except for the top. Then I used the Carve Tool with the cylinder selected and ended up with very strange, infinitely long shapes stuck to the inner sphere. In the end, I just deleted the whole thing.

Could you please post screenshots of this, or the map file with all steps done but the last (Carve)?
This sounds like a bug in CaWE, but in order to fix it, I have to be able to reproduce it first.

3. Next I made a 360 degree arch, placed a thin box brush over the whole arch, selected the arch and used the Carved Tool. This allowed me to select and delete all the outer parts of the thin box brush, so that I could keep the center to use as a floor (and roof when duplicated). This worked great, but when I loaded the map I noticed two problems: [...]

Also for this, could you please post (or sent per PM or mail) screenshots or the map file?

I would really like to use Cafu, but I keep running into weird little time sinks like this that have me wondering if it's me who is causing them or if it's the CaWE tool bugging out. I really hope that it's just me going about doing the simplest of tasks in the least efficient, most prone to causing bugs way possible, because I do enjoy working with CaWE/Cafu when it works properly. :lol:

Yes, I'm sorry about the trouble. All of these sound like problems in CaWE, not a result of your using. Reporting the problems is the first step to get them fixed, though. (And the more you can help with the fixes, the better. :up: )
Best regards,
Carsten

Return to “Editing and Mapping with CaWE”

Who is online

Users browsing this forum: No registered users and 1 guest