CaWE high CPU usage

A forum about everything related to the Cafu World Editor CaWE: mapping, editing, scripting, making GUIs and fonts, using the BSP, PVS and Light compilers.
D4rkTorq
Posts: 2
Joined: 2013-03-08, 14:58

CaWE high CPU usage

Postby D4rkTorq » 2013-03-08, 15:32

When CaWE window doesn't have the focus, or is minimized the process utilizes almost 100% of CPU (=fan getting louder), which gets back to normal when the window becomes active. It seems to me that this happens only when open documents are maps (or one map, empty or not), but as soon as I add e.g. a new model document the problem disappears. Do you have any idea what might be the cause here?

Thanks
User avatar
Carsten
Site Admin
Posts: 2143
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: CaWE high CPU usage

Postby Carsten » 2013-03-10, 20:55

Hi D4rkTorq,
welcome to the Cafu forums! :welcome:

D4rkTorq wrote:When CaWE window doesn't have the focus, or is minimized the process utilizes almost 100% of CPU (=fan getting louder), which gets back to normal when the window becomes active. It seems to me that this happens only when open documents are maps (or one map, empty or not), but as soon as I add e.g. a new model document the problem disappears. Do you have any idea what might be the cause here?


Well, not really. Rendering a map is an expensive operation, and it is perfectly expected to consume resources like CPU and GPU time aplenty.

When a new map is loaded, it lazily caches in additional texture images, which, unless the user forces a quicker access to the texture images, may take several minutes, then stops. Maybe this is what you're seeing.

In any case, from your description it doesn't sound as if anything abnormal was going on.
:up:
Best regards,
Carsten

Return to “Editing and Mapping with CaWE”

Who is online

Users browsing this forum: No registered users and 2 guests