Page 1 of 1

Camera Flying Up Error (CaWE)

Posted: 2012-02-26, 19:51
by redemptionstudios
Hi, I've been editing my first map in CaWE and after I compiled it for the first time and tested it and once I got back to the World Editor, the camera just randomly began to fly up on z-axis (I believe) leaving my map long gone. I can't seem to stop this now. I restart the World Editor and reload the map. I've even tried recompiling it. How do I fix this?

Thanks in advance!

Re: Camera Flying Up Error (CaWE)

Posted: 2012-02-27, 00:59
by Carsten
Hi redemptionstudios,
welcome to the Cafu forums! :welcome:

Which source code do you use: the r418 release from the downloads page, or SVN head from the Subversion repository?
Which platform, OS and compiler do you use?
Can you reproduce this? If so, how? (Which key presses or mouse clicks are involved?)

Re: Camera Flying Up Error (CaWE)

Posted: 2012-03-03, 01:44
by redemptionstudios
I am using the r398 (32 bit) Binary download of Cafu. Currently using Microsoft Windows XP x64. Also, I noticed I said, "I've even tried recompiling it." I made a mistake when I said this. I meant I've re-built the game from CaWE multiple times and the "error" has persisted. I do not have the SVN version of Cafu.

The "error" occurs when right after I do my first build of a map fro CaWE (after I get back into CaWE). It appears that the "error" is fixed by restarting the computer, but still exists with new maps. It's a bit annoying to restart your computer for every map. Anyway, best of luck!

Re: Camera Flying Up Error (CaWE)

Posted: 2012-03-04, 22:51
by Carsten
Well, the problem is that I cannot reproduce this here, using 64-bit Windows 7 and 32-bit Cafu code.
When I load a map in CaWE, click "Compile - Run Quick...", then the map compiles, the engine starts, and when I quit, it returns to the editor as expected.

It would be helpful if you could provide instructions on how this can be reproduced in order to get it fixed.