repository broken?

Get help with installing and running the Cafu Engine here. This forum is also for general questions and discussion of all aspects regarding the Cafu Engine.
Post Reply
User avatar
arfur9
Posts: 90
Joined: 2017-02-25, 18:57
Location: uk
Contact:

repository broken?

Post by arfur9 » 2020-02-02, 11:51

There seems to be an issue with ExtLibs/glfw, the folder content isn't cloned, it appears https://github.com/CarstenF/glfw.git is no longer there?

I tried to add libglfw-dev but this is obsolete its now libglfw3-dev
This is Raspbian Debian Buster btw
User avatar
Carsten
Site Admin
Posts: 2169
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: repository broken?

Post by Carsten » 2020-02-03, 00:15

Sorry for the trouble!
I renamed my account at GitHub (CarstenF is now carstenfuchs) and forgot to update the related submodule URL, which is now https://github.com/carstenfuchs/glfw.git
I've just pushed a commit that updates the GLFW submodule's URL. Can you please try if that works?
Best regards,
Carsten
User avatar
arfur9
Posts: 90
Joined: 2017-02-25, 18:57
Location: uk
Contact:

Re: repository broken?

Post by arfur9 » 2020-02-03, 10:02

Hi, yes its working fine now.. I haven't tried on Linux yet but it cloned ok with Windows :)
User avatar
arfur9
Posts: 90
Joined: 2017-02-25, 18:57
Location: uk
Contact:

Re: repository broken?

Post by arfur9 » 2020-02-03, 11:10

I now get "Unknown compiler 14.1 on platform win32." I'm on VS2017
edit:
nevermind I forgot about the CompilerSetup.py setting :oops: I have earlier versions of VS I can use

edit2:
the snprintf issue is still there:
viewtopic.php?f=6&t=1990&p=7200&hilit=snprintf#p7200
Post Reply

Who is online

Users browsing this forum: No registered users and 3 guests