CaWE not running; asking for 32 BPP, WHICH I HAVE!!

Get help with installing and running the Cafu Engine here. This forum is also for general questions and discussion of all aspects regarding the Cafu Engine.
Post Reply
User avatar
Viggsy
Posts: 3
Joined: 2010-08-16, 03:56
Contact:

CaWE not running; asking for 32 BPP, WHICH I HAVE!!

Post by Viggsy » 2010-08-16, 04:40

Hi, I am an amateur Lua scripter and I am new to Cafu. This is the only engine that I have found that uses Lua and isn't insanely complex.

I just downloaded Cafu (Ca3DE-9.06, June 2009 Windows) and ran Ca3DE.exe, no problems occured.

However, I just attempted to run CaWE.exe and it gives me this EXACT error message right upon starting, before anything else even happens:


"Renderer ../Libs/build/win32/vc8/release/MaterialSystem/RendererOpenGL12.dll says that it's not supported.

(This may be caused by your desktop being set to 16 BPP (or less).
Please set your desktop bit-depth to 32 BPP (True Color), and try again.)"


This is really, REALLY ticking me off. I just checked my settings, and I HAVE 32 BPP (TRUE COLOR)!! I have no idea why this isn't working. I have a year 2000 Insignia computer with Windows XP 2000 on it, with a default graphics card (Intel(R) 82845G/GL/GE/PE/GV Graphics Controller), and I'm pretty sure it stated somewhere before the download that Cafu can run on these reqs.

Someone please help me, I'm about to go ballistic if this doesn't get fixed.

IMPORTANT NOTICE: I AM NOT A COMPUTER WIZZ. I have an average knowledge level of computers, nothing more. I can't take apart a computer and put it back together like you geniuses out there, please don't give me an answer like "Default your java code 89.1 to Level 10" or whatever, please talk to me in the simplest form possible.
Image
"Many men who live deserve death, and many men who are dead, deserve life."
User avatar
Carsten
Site Admin
Posts: 2160
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: CaWE not running; asking for 32 BPP, WHICH I HAVE!!

Post by Carsten » 2010-08-16, 11:02

Hi Viggsy,
welcome to the Cafu forums! :welcome:
"Renderer ../Libs/build/win32/vc8/release/MaterialSystem/RendererOpenGL12.dll says that it's not supported.

(This may be caused by your desktop being set to 16 BPP (or less).
Please set your desktop bit-depth to 32 BPP (True Color), and try again.)"

This is really, REALLY ticking me off. I just checked my settings, and I HAVE 32 BPP (TRUE COLOR)!!
Relax, it says it may be caused by non-32 BPP settings, not that it must be caused by it.
Nevertheless, I suspect that your on-board graphics may well be the source of the problems. As a first step, could you please get and install the latest graphics driver for your system? I did a quick search and found e.g. http://www.intel.com/support/graphics/i ... 009072.htm that seems to apply.

Please let us know if it helps. However if it doesn't, it's most likely failing the additional requirements that Cafu (or any modern 3D engine) needs: sufficiently precise depth buffer and at least 8 bits of stencil buffer (the latter might be the culprit...).
(If it still doesn't work after you've upgraded the driver, could you please post the full output of console messages?)
Best regards,
Carsten
User avatar
Viggsy
Posts: 3
Joined: 2010-08-16, 03:56
Contact:

Re: CaWE not running; asking for 32 BPP, WHICH I HAVE!!

Post by Viggsy » 2010-08-16, 21:08

You. Are. A. Genius.
It worked!! Thank you very much for providing me with understandable information and even a link. The Cafu world editor is now working, I'm really excited to script something!
Image
"Many men who live deserve death, and many men who are dead, deserve life."
Jianju
Posts: 4
Joined: 2010-09-29, 23:55

Re: CaWE not running; asking for 32 BPP, WHICH I HAVE!!

Post by Jianju » 2010-09-30, 00:11

Hello,

I'm new here. Just installed Cafu, & I'm having the same problem. I updated my video card drivers, but to no avail. I've got an Nvidea Quadro FX1500, normally for CAD work, but it plays most all 3D games just fine. Is it unsuitable for Cafu?

Here's the error message from my console shell:
C:\Cafu\Ca3DE-9.06>Ca3DE -noFS
Ca3D-Engine, May 25 2009
Ca3DE is getting hotter: Renamed to Cafu Engine soon!
config.lua processed.
Registering archive "Games/DeathMatch/Textures/TechDemo.zip".
Registering archive "Games/DeathMatch/Textures/SkyDomes.zip".

Scanning cwd for all available renderers...
./RendererARBprogs.dll ... FAILED - renderer says it's not supported.
./RendererCgARB1.dll ... FAILED - renderer says it's not supported.
./RendererCgNV2X.dll ... FAILED - renderer says it's not supported.
./RendererNull.dll ... SUCCESS - but excluded from auto-selection (Pref# 1).
./RendererOpenGL12.dll ... FAILED - renderer says it's not supported.
No renderer qualified.
Sorry, was not able to find any renderer that is supported on your system.

C:\Cafu\Ca3DE-9.06>
I've done 3D development in the past, but always with a tool, such as MAX or Maya, plus scripting with VRML, stuff like that. I'm new to getting under the hood & coding these things up in C++, so I may not have done all the necessary groundwork yet. Do I need to install OpenGL somehow??

Thanks for any guidance,

Jack
User avatar
Carsten
Site Admin
Posts: 2160
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: CaWE not running; asking for 32 BPP, WHICH I HAVE!!

Post by Carsten » 2010-09-30, 11:16

Hi Jianju,
welcome to the Cafu forums! :welcome:

OpenGL is installed with the graphics driver, so normally you have it already. (Nonetheless, it is worth to double-check if you have the latest drivers from NVidia).

Also, please check if your desktop is set to 32 BPP ("True Color", Highest) color depth (instructions).

Finally, it may help to get the latest development version (currently r154), which has the same OpenGL requirements as before, but improved window handling.

If all else fails, please let me know, I'll then upload a version of Cafu that outputs more diagnostics to better locate the source of the problem.
Best regards,
Carsten
Jianju
Posts: 4
Joined: 2010-09-29, 23:55

Re: CaWE not running; asking for 32 BPP, WHICH I HAVE!!

Post by Jianju » 2010-09-30, 16:57

Carsten, thanks for your reply!

I verified that I am indeed in 32-bit True Color mode.

Sorry, I misunderstood when I posted on this thread instead of starting a new one; my problem appears to be something completely different. I'm downloading the development version to see if that makes a difference..

More about my system:

Windows 7 Ultimate
Nvidia Nforce 680i SLI Motherboard
Nvidia Quadro FX1500
1GB RAM

Anything else I can provide?

Will post again when I've tried the development version.

Thanks again,

-Jack
Jianju
Posts: 4
Joined: 2010-09-29, 23:55

Re: CaWE not running; asking for 32 BPP, WHICH I HAVE!!

Post by Jianju » 2010-09-30, 17:43

Okay, I notice that on the dev release there are seperate versions for 32 & 64 bit, whereas before there was only one 32-bit version. 32-bit *should* run fine on my 64bit system (sorry, forgot to mention 64bit) but let's see how the specific 64bit dev version runs... checking now...
Jianju
Posts: 4
Joined: 2010-09-29, 23:55

Re: CaWE not running; asking for 32 BPP, WHICH I HAVE!!

Post by Jianju » 2010-09-30, 17:56

Okay, the dev version works just fine. Great work, Carsten! I hope to learn more about how you accomplished this. With time & study, I hope to accomplish something similar.

Thanks,

Jack
User avatar
Carsten
Site Admin
Posts: 2160
Joined: 2004-08-19, 13:46
Location: Germany
Contact:

Re: CaWE not running; asking for 32 BPP, WHICH I HAVE!!

Post by Carsten » 2010-10-01, 11:38

Jianju wrote:Okay, the dev version works just fine. Great work, Carsten!
Great to hear this, thanks! :wohow:
Best regards,
Carsten
Post Reply

Who is online

Users browsing this forum: No registered users and 2 guests